aboutsummaryrefslogtreecommitdiffstats
path: root/maint/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-03-25 04:00:30 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-03-25 04:00:30 +0800
commitdcec8c208697106401f714547a79afe48acf750b (patch)
tree455b6136f7272ee9e93f553d00bade1a357e8394 /maint/Makefile.am
parent37287b0f468259ef56bb7cfa9c0bcdc157456b94 (diff)
downloadgsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.tar
gsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.tar.gz
gsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.tar.bz2
gsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.tar.lz
gsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.tar.xz
gsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.tar.zst
gsoc2013-evolution-dcec8c208697106401f714547a79afe48acf750b.zip
Add a Glade 3 catalog.
Evolution maintainers should install this so they can safely open GtkBuilder files in Glade 3 without Glade silently deleting custom widgets it doesn't understand. The catalog makes it understand.
Diffstat (limited to 'maint/Makefile.am')
-rw-r--r--maint/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/maint/Makefile.am b/maint/Makefile.am
new file mode 100644
index 0000000000..950be7cadd
--- /dev/null
+++ b/maint/Makefile.am
@@ -0,0 +1,25 @@
+### Process this file with automake to produce Makefile.in
+
+gladecatalog_DATA = evolution.xml
+gladecatalogdir = `$(PKG_CONFIG) --variable=catalogdir gladeui-1.0`
+
+gladeevolution_LTLIBRARIES = libgladeevolution.la
+gladeevolutiondir = `$(PKG_CONFIG) --variable=moduledir gladeui-1.0`
+
+libgladeevolution_la_SOURCES =
+
+libgladeevolution_la_LDFLAGS = \
+ -module -avoid-version
+
+libgladeevolution_la_LIBADD = \
+ $(top_srcdir)/mail/libevolution-mail.la \
+ $(top_srcdir)/calendar/gui/libevolution-calendar.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(EVOLUTION_CALENDAR_LIBS) \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+EXTRA_DIST = \
+ $(gladecatalog_DATA)
+
+-include $(top_srcdir)/git.mk