aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorEskil Heyn Olsen <eskil@src.gnome.org>1999-10-06 23:23:18 +0800
committerEskil Heyn Olsen <eskil@src.gnome.org>1999-10-06 23:23:18 +0800
commitfe4a9b93de19146309bf95f3ebaf1314069c1503 (patch)
treebf30984d9d13c663b3e1eb80d49b468b4ca182b6 /calendar/Makefile.am
parentf0ba84bd71a02e1b6af050d6f3f6d2d31d08a3e5 (diff)
downloadgsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.tar
gsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.tar.gz
gsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.tar.bz2
gsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.tar.lz
gsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.tar.xz
gsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.tar.zst
gsoc2013-evolution-fe4a9b93de19146309bf95f3ebaf1314069c1503.zip
checks return values from gpilotd_init/connect.
* *conduit*[ch]: checks return values from gpilotd_init/connect. * calender.c (vcalendar_create_from_calendar): removed a set of cleanVObject cleanStrTbl, since the freed memory that the function returned. svn path=/trunk/; revision=1319
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 5ed3d8fbae..1b4927e0aa 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -9,7 +9,11 @@ gnorba_DATA = gnomecal.gnorba
help_base = $(datadir)/gnome/help/cal
if HAVE_GNOME_PILOT
-bin_PROGRAMS = gnomecal todo-conduit-control-applet calendar-conduit-control-appleta calendar-pilot-sync
+bin_PROGRAMS = \
+ gnomecal \
+ todo-conduit-control-applet \
+ calendar-conduit-control-applet \
+ calendar-pilot-sync
else
bin_PROGRAMS = gnomecal
endif
@@ -115,21 +119,22 @@ calendar_pilot_sync_LDADD = \
$(LINK_FLAGS)
-if HAVE_GNOME_PILOT
#calendar_conduit
calendar_conduitsdir=$(libdir)/gnome-pilot/conduits
calendar_conduits_LTLIBRARIES = libcalendar_conduit.la
libcalendar_conduit_la_SOURCES = \
+ GnomeCal-common.c \
+ GnomeCal-stubs.c \
calendar-conduit.c \
calobj.c \
alarm.c \
- GnomeCal-common.c \
- GnomeCal-stubs.c \
calendar.c \
timeutil.c
+calendar-conduit.c: my_gnomecal_idl
+
libcalendar_conduit_la_LDFLAGS = \
-rpath $(libdir)
@@ -167,6 +172,8 @@ libtodo_conduit_la_LIBADD = \
libtodo_conduit_la_SOURCES = \
todo-conduit.c
+todo-conduit.c: GnomeCal.h
+
todo_conduit_control_applet_SOURCES = \
todo-conduit-control-applet.c
@@ -179,7 +186,6 @@ todo_conduit_control_applet_LDADD = \
$(PISOCK_LIBS) \
$(GNOME_PILOT_LIBS) \
$(INTLLIBS)
-endif # HAVE_GNOME_PILOT
gnomecal_LDADD = $(LINK_FLAGS)