aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorEskil Olsen <deity@eskil.dk>1999-11-04 22:20:13 +0800
committerEskil Heyn Olsen <eskil@src.gnome.org>1999-11-04 22:20:13 +0800
commitee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1 (patch)
treeb86e053a84983e8604cdb5c7f34d440ad9a477f9 /calendar/Makefile.am
parenta6c4b535334a6da5c8d1622b11a0893d0c55abee (diff)
downloadgsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.tar
gsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.tar.gz
gsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.tar.bz2
gsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.tar.lz
gsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.tar.xz
gsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.tar.zst
gsoc2013-evolution-ee413a3fd2c6ee802b6af1286f1cf7a65f52c5f1.zip
Uses the PISOCK_LIBDIR, for people with odd install dirs for their
1999-11-04 Eskil Olsen <deity@eskil.dk> * Makefile.am: Uses the PISOCK_LIBDIR, for people with odd install dirs for their pilot-link. Also install a pretty icon for the calendar-conduit. * calendar-conduit-control-applet.c: Modfied the try/revert/ok/cancel scheme to be more intuitive, also uses a GtkOptionMenu for the possible sync methods. * calendar-conduit-control-applet.desktop: use the nice icon... * calendar-conduit.c: Ack, had to define debug_alarms and alarm_default, otherwise they are undefined. Is gncal code messy or is this considered a way of configuring the cal engine ? Implemented delete_all syncabs methods. * calendar-pilot-sync.c: also had to declare debug_alarms and alarm_defaults, just as ugly. svn path=/trunk/; revision=1367
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 4042368bff..f08b4df06a 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -114,7 +114,7 @@ LINK_FLAGS = \
../libversit/libversit.la
calendar_pilot_sync_LDADD = \
- $(PISOCK_LIBS) \
+ $(PISOCK_LIBDIR) $(PISOCK_LIBS) \
$(LINK_FLAGS)
if HAVE_GNOME_PILOT
@@ -139,7 +139,7 @@ libcalendar_conduit_la_LDFLAGS = \
libcalendar_conduit_la_LIBADD = \
../libversit/libversit.la \
- $(PISOCK_LIBS) \
+ $(PISOCK_LIBDIR) $(PISOCK_LIBS) \
$(GNOME_LIBDIR) \
$(GNOME_LIBS)
@@ -150,9 +150,8 @@ calendar_conduit_control_applet_LDADD = \
$(CAPPLET_LIBS) \
$(GNOME_LIBDIR) \
$(GNOME_CAPPLET_LIBS) \
- $(PISOCK_LIBS) \
+ $(PISOCK_LIBDIR) $(PISOCK_LIBS) \
$(GNOMEUI_LIBS) \
- $(PISOCK_LIBS) \
$(GNOME_PILOT_LIBS) \
$(INTLLIBS)
@@ -180,9 +179,8 @@ calendar_conduit_control_applet_LDADD = \
# $(CAPPLET_LIBS) \
# $(GNOME_LIBDIR) \
# $(GNOME_CAPPLET_LIBS) \
-# $(PISOCK_LIBS) \
+# $(PISOCK_LIBDIR) $(PISOCK_LIBS) \
# $(GNOMEUI_LIBS) \
-# $(PISOCK_LIBS) \
# $(GNOME_PILOT_LIBS) \
# $(INTLLIBS)
endif
@@ -205,7 +203,11 @@ EXTRA_DIST = \
bell.xpm \
recur.xpm \
$(idl_DATA) \
- $(gnorba_DATA)
+ $(gnorba_DATA) \
+ gnome-calendar-conduit.png
+
+appicondir = $(datadir)/pixmaps
+appicon_DATA = gnome-calendar-conduit.png
Productivitydir = $(datadir)/gnome/apps/Applications