aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorMiguel de Icaza <miguel@gnu.org>1999-07-28 16:41:12 +0800
committerArturo Espinosa <unammx@src.gnome.org>1999-07-28 16:41:12 +0800
commite49e9cc1755266dade86ce33662ceff466f5ca07 (patch)
tree9c26f2dea9902aef6d691d70ddeee07293cba176 /calendar/Makefile.am
parent81207158058c5f5e4315e3b66f92a46aec64e5ae (diff)
downloadgsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.tar
gsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.tar.gz
gsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.tar.bz2
gsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.tar.lz
gsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.tar.xz
gsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.tar.zst
gsoc2013-evolution-e49e9cc1755266dade86ce33662ceff466f5ca07.zip
New file. Implements PalmPilot syncronization with the Gnome Calendar.
1999-07-28 Miguel de Icaza <miguel@gnu.org> * calendar-pilot-sync.c: New file. Implements PalmPilot syncronization with the Gnome Calendar. 1999-07-27 Miguel de Icaza <miguel@gnu.org> * calobj.c (ical_object_new_from_string): New function. Creates an iCalObject from a vCalendar string that is supposed to contain only one vEvent. * calendar.c: (calendar_save): Split this routine in two. * gnome-cal.c (gnome_calendar_new): Create the corba server here. * main.c: Include gnorba.h, and corba-cal-factory.h here (close_cmd): Kill the calendar server on shutdown. * calobj.c (load_recur_yearly_day): Added a fixme comment. WE need to handle intervals in the years. * calendar.c (calendar_object_find_in_list, calendar_object_find, calendar_object_find_todo, calendar_object_find_event): New functions for looking up information. * main.c (gnome_calendar_locate): New function. * corba-cal.c (calendar_create_object): New file. Implements the corba server. * calendar.c (calendar_object_changed): Flag pilot-status as changed. * calobj.c (ical_object_to_vobject): Save pilot information for syncing. (ical_object_create_from_vobject): Load syncing information for pilot. Do it in a way compatible with KOrganizer. 1999-07-26 Miguel de Icaza <miguel@gnu.org> * calobj.c (ical_object_create_from_vobject): Generate unique IDs on Vevents we load that lack it. WE need this for the old gnome calendar generated files (ie, before now :-). svn path=/trunk/; revision=1038
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am48
1 files changed, 45 insertions, 3 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 151ce8d64b..e4fa401aad 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -1,17 +1,36 @@
SUBDIRS = doc
+idldir = $(datadir)/idl
+idl_DATA = GnomeCal.idl
+
+gnorbadir = $(sysconfdir)/CORBA/servers
+gnorba_DATA = gnomecal.gnorba
+
help_base = $(datadir)/gnome/help/cal
-CFLAGS += -Wall
+CFLAGS += -Wall -Wunused -Wpointer-arith -Wmissing-declarations
INCLUDES = \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
-bin_PROGRAMS = gnomecal
+bin_PROGRAMS = gnomecal calendar-pilot-sync
+
+GNOMECAL_CORBA_GENERATED = \
+ GnomeCal.h \
+ GnomeCal.c \
+ GnomeCal-common.c \
+ GnomeCal-skels.c \
+ GnomeCal-stubs.c
+
+$(GNOMECAL_CORBA_GENERATED): GnomeCal.idl
+ orbit-idl GnomeCal.idl
gnomecal_SOURCES = \
+ GnomeCal-common.c \
+ GnomeCal-skels.c \
+ GnomeCal.h \
alarm.c \
alarm.h \
calendar.c \
@@ -21,6 +40,10 @@ gnomecal_SOURCES = \
eventedit.c \
eventedit.h \
getdate.y \
+ corba-cal.c \
+ corba-cal.h \
+ corba-cal-factory.c \
+ corba-cal-factory.h \
gncal-day-panel.c \
gncal-day-panel.h \
gncal-day-view.c \
@@ -57,11 +80,28 @@ gnomecal_SOURCES = \
year-view.c \
year-view.h
+calendar_pilot_sync_SOURCES = \
+ GnomeCal-common.c \
+ GnomeCal-stubs.c \
+ alarm.c \
+ calendar-pilot-sync.c \
+ calobj.c \
+ calobj.h \
+ calendar.c \
+ calendar.h \
+ timeutil.c \
+ timeutil.h
+
LINK_FLAGS = \
$(GNOME_LIBDIR) \
$(GNOMEGNORBA_LIBS) \
$(INTLLIBS) ../libversit/libversit.a
+PILOT_LIBS = -lpisock
+
+calendar_pilot_sync_LDADD = \
+ $(PILOT_LIBS) \
+ $(LINK_FLAGS)
#gncal_LDADD = $(LINK_FLAGS)
@@ -70,7 +110,9 @@ gnomecal_LDADD = $(LINK_FLAGS)
EXTRA_DIST = \
gncal.desktop \
bell.xpm \
- recur.xpm
+ recur.xpm \
+ $(idl_DATA) \
+ $(gnorba_DATA)
Productivitydir = $(datadir)/gnome/apps/Applications