aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@nuclecu.unam.mx>1998-08-30 09:29:19 +0800
committerArturo Espinosa <unammx@src.gnome.org>1998-08-30 09:29:19 +0800
commite0d99122ab17d9bf356cf793b41aec6b6d6016b1 (patch)
treeb2f202ce6ea0b927a8fa4929034c84af223ef782 /calendar/Makefile.am
parent9b6991077bd564348e9dd229ca523bdaa8239ed1 (diff)
downloadgsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.tar
gsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.tar.gz
gsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.tar.bz2
gsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.tar.lz
gsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.tar.xz
gsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.tar.zst
gsoc2013-evolution-e0d99122ab17d9bf356cf793b41aec6b6d6016b1.zip
Centralized marking of month items. We now have a little utility function
Centralized marking of month items. We now have a little utility function to colorify the days in a month item that have events scheduled for them. This is currently used by the year view and the go-to dialog. Fixed buglets here and there. 1998-08-29 Federico Mena Quintero <federico@nuclecu.unam.mx> * mark.[ch]: New files with utility functions to mark calendars with their events. * mark.c (mark_month_item): New public function to mark a month item with events. (unmark_month_item): New public function to unmark all the days in a month item to their default appearance. * year-view.c (year_view_set): Use the new unmark_month_item() and mark_month_item() to mark the months with events. * goto.c (update): New function that updates the calendar in the Go-to dialog by marking the days. * timeutil.c (time_year_begin): Modified to take a time_t value. (time_year_end): Likewise. (time_month_begin): Actually implemented this function, which was in the header file but not here. (time_days_in_month): New public function that returns the number of days in a month. * Makefile.am (gnomecal_SOURCES): Added mark.[ch] to the sources. * year-view.c (unmark_days): Use unmark_month_item(). * gncal-full-day.c (gncal_full_day_destroy): Fixed crash when destroying the full day view. The full day's destroy method is unusual in that it destroys the list of child widgets itself, as it does not have a remove method, so it needs to reset the list to NULL. svn path=/trunk/; revision=351
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index dfd034e433..9e4163c932 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -38,6 +38,8 @@ gnomecal_SOURCES = \
goto.c \
main.c \
main.h \
+ mark.c \
+ mark.h \
month-view.c \
month-view.h \
popup-menu.c \