aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-02-08 15:08:29 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-02-08 15:08:29 +0800
commitcc670cb2ca319599eebac658f1164dbb64d70c65 (patch)
tree55dc72c7ea1b1582158e8aa55eedb9d18a4ab4e4 /calendar/Makefile.am
parentc02660b4081a84c9ad5749a931f5458f08f634d3 (diff)
downloadgsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.tar
gsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.tar.gz
gsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.tar.bz2
gsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.tar.lz
gsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.tar.xz
gsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.tar.zst
gsoc2013-evolution-cc670cb2ca319599eebac658f1164dbb64d70c65.zip
New struct to wrap instances of calendar objects for recurrencies and
2000-02-08 Federico Mena Quintero <federico@helixcode.com> * evolution-calendar.idl (CalObjInstance): New struct to wrap instances of calendar objects for recurrencies and alarms. (Cal::get_events_in_range): New method to get ocurring and recurring events by time range. * cal-backend.c (cal_backend_get_events_in_range): New function to get a list of event instances in a time range. (string_from_ical_object): New internal function. (cal_backend_get_object): Use string_from_ical_object() instead of doing everything ourselves. (cal_backend_get_events_in_range): New function to get a list of the events that occur or recur in a specified time range. * cal-client.c (cal_client_get_events_in_range): Implemented client-side function. * cal-util.h: * cal-util.c: New files with utilities and types common to the client and server parts. (CalObjInstance): New structure to hold an instance of an actual occurrence, recurrence, or alarm trigger of a calendar object. (cal_obj_instance_list_free): New function to free a list of calendar object instances. * cal.c (Cal_get_events_in_range): Implemented new method. * corba-cal.c (cal_repo_get_updated_objects): Free `str' with free(), not g_free(), since calendar_get_as_vcal_string() uses writeMemVObject(), which uses realloc(). Fixed in gnome-pim as well. svn path=/trunk/; revision=1693
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 408f80dd76..5fa18ba0dd 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -62,6 +62,8 @@ gnomecal_SOURCES = \
cal-client.h \
cal-listener.c \
cal-listener.h \
+ cal-util.c \
+ cal-util.h \
calendar.c \
calendar.h \
calendar-conduit.h \
@@ -134,6 +136,8 @@ tlacuache_SOURCES = \
cal-common.h \
cal-factory.c \
cal-factory.h \
+ cal-util.c \
+ cal-util.h \
calobj.c \
calobj.h \
job.c \