aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-03-04 11:58:38 +0800
committerSeth Alves <alves@src.gnome.org>2000-03-04 11:58:38 +0800
commitc6c65136bb37bd87e9d50735e1543bd296ee513d (patch)
treebae8f8cc3283a1dd94b2fa11ed1352e66acdd067 /calendar/Makefile.am
parent7f1494e3f4b335c61b579c0568538ec83e6d30ee (diff)
downloadgsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.gz
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.bz2
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.lz
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.xz
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.zst
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.zip
new file -- things shared between the client and server go in this
* cal-util/Makefile.am: new file -- things shared between the client and server go in this directory * calobj.c calobj.h icalendar.c icalendar.h timeutil.c timeutil.h cal-util.c cal-util.h where moved backend stuff went into pcs. shared stuff went into cal-util. svn path=/trunk/; revision=2032
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am23
1 files changed, 13 insertions, 10 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index d9001476a4..40e1357a62 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = doc idl pcs cal-client
+SUBDIRS = doc idl cal-util pcs cal-client
idldir = $(datadir)/idl
idl_DATA = \
@@ -27,7 +27,8 @@ INCLUDES = \
$(BONOBO_VFS_GNOME_CFLAGS) \
$(GNOME_CONDUIT_INCLUDEDIR) \
$(PISOCK_INCLUDEDIR) \
- -I../libical/src/libical \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libical/src/libical \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
GNOMECAL_CORBA_GENERATED = \
@@ -51,11 +52,7 @@ gnomecal_SOURCES = \
GnomeCal.h \
alarm.c \
alarm.h \
- calendar.c \
- calendar.h \
calendar-conduit.h \
- calobj.c \
- calobj.h \
eventedit.c \
eventedit.h \
corba-cal.c \
@@ -78,8 +75,6 @@ gnomecal_SOURCES = \
gnome-cal.c \
gnome-cal.h \
goto.c \
- icalendar.c \
- icalendar.h \
layout.c \
layout.h \
main.c \
@@ -93,14 +88,21 @@ gnomecal_SOURCES = \
prop.c \
quick-view.c \
quick-view.h \
- timeutil.c \
- timeutil.h \
todo-conduit.h \
view-utils.h \
view-utils.c \
year-view.c \
year-view.h
+# calendar.c \
+# calendar.h \
+# calobj.c \
+# calobj.h \
+# icalendar.c \
+# icalendar.h \
+# timeutil.c \
+# timeutil.h \
+
calendar_pilot_sync_SOURCES = \
GnomeCal-common.c \
GnomeCal-stubs.c \
@@ -116,6 +118,7 @@ calendar_pilot_sync_SOURCES = \
LINK_FLAGS = \
$(BONOBO_VFS_GNOME_LIBS) \
$(INTLLIBS) \
+ cal-util/libcalutil.la \
../libversit/libversit.la \
$(ICAL_LINK_FLAGS)