aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-03-02 05:13:26 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-03-02 05:13:26 +0800
commit84757ca4db2163b8964a84b136c71d8a1ae6040d (patch)
tree76dc3a3806b1c168ca185cded89c26eb246ebf67 /calendar/Makefile.am
parent339167a0c9b34b27a97e6e76b88adfc8d0f9232a (diff)
downloadgsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.tar
gsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.tar.gz
gsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.tar.bz2
gsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.tar.lz
gsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.tar.xz
gsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.tar.zst
gsoc2013-evolution-84757ca4db2163b8964a84b136c71d8a1ae6040d.zip
Use the gnome-config flags for orbit-idl. Create a libcal-client library
2000-03-01 Federico Mena Quintero <federico@helixcode.com> * Makefile.am: Use the gnome-config flags for orbit-idl. Create a libcal-client library with the calendar client object. svn path=/trunk/; revision=2000
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 8e2ea78dde..da5a843d0b 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -5,6 +5,8 @@ idl_DATA = \
GnomeCal.idl \
evolution-calendar.idl
+idl_flags = `$(GNOME_CONFIG) --cflags idl`
+
gnorbadir = $(sysconfdir)/CORBA/servers
gnorba_DATA = \
gnomecal.gnorba \
@@ -20,6 +22,8 @@ endif
bin_PROGRAMS = gnomecal tlacuache $(extra_pilot_bins)
+lib_LTLIBRARIES = libcal-client.la
+
ICAL_LINK_FLAGS = ../libical/src/libical/libical.la
INCLUDES = \
@@ -38,7 +42,7 @@ GNOMECAL_CORBA_GENERATED = \
GnomeCal-stubs.c
$(GNOMECAL_CORBA_GENERATED): GnomeCal.idl
- orbit-idl $(srcdir)/GnomeCal.idl
+ $(ORBIT_IDL) $(idl_flags) $(srcdir)/GnomeCal.idl
corba-cal.c \
corba-cal.h \
@@ -52,7 +56,7 @@ EVOLUTION_CALENDAR_CORBA_GENERATED = \
evolution-calendar-stubs.c
$(EVOLUTION_CALENDAR_CORBA_GENERATED): evolution-calendar.idl
- orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl $(srcdir)/evolution-calendar.idl
+ $(ORBIT_IDL) $(idl_flags) $(srcdir)/evolution-calendar.idl
gnomecal_SOURCES = \
$(EVOLUTION_CALENDAR_CORBA_GENERATED) \
@@ -129,6 +133,27 @@ calendar_pilot_sync_SOURCES = \
timeutil.c \
timeutil.h
+#
+# cal-client library
+#
+
+libcal_clientincludedir = $(includedir)/cal-client
+
+libcal_client_la_SOURCES = \
+ $(EVOLUTION_CALENDAR_CORBA_GENERATED) \
+ cal-client.c \
+ cal-listener.c \
+ cal-util.c
+
+libcal_clientinclude_HEADERS = \
+ cal-client.h \
+ cal-listener.h \
+ cal-util.h
+
+#
+# tlacuache personal calendar server
+#
+
tlacuache_SOURCES = \
$(EVOLUTION_CALENDAR_CORBA_GENERATED) \
alarm.c \