aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-02-18 05:30:09 +0800
committerSeth Alves <alves@src.gnome.org>2000-02-18 05:30:09 +0800
commit4cd07c4e96046f0151528ba585de8d4472e0fbe5 (patch)
tree099951cfea95af02f479cd8d5cb3dcec923ef05f /calendar/Makefile.am
parentc975d4ef24b4db28b19faf6d2b1e5d1956fe836c (diff)
downloadgsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.tar
gsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.tar.gz
gsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.tar.bz2
gsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.tar.lz
gsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.tar.xz
gsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.tar.zst
gsoc2013-evolution-4cd07c4e96046f0151528ba585de8d4472e0fbe5.zip
moved CalendarFormat type def here
* cal-backend.h: moved CalendarFormat type def here * cal-backend.c (cal_backend_load): if extension suggests an ical file, attempt to load an iCal file. (cal_get_type_from_filename): returns CAL_ICAL if file extension is 'ics' or 'ifb', else returns CAL_VCAL (icalendar_calendar_load): moved this here from icalendar.c because it needs to call the static function add_object. svn path=/trunk/; revision=1831
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 1762bc0bf7..575344e651 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -20,19 +20,14 @@ endif
bin_PROGRAMS = gnomecal tlacuache $(extra_pilot_bins)
-#if HAVE_LIBICAL
-ICAL_INCLUDEDIR = -I../libical/src/libical
-ICAL_SOURCES = icalendar.c
ICAL_LINK_FLAGS = ../libical/src/libical/libical.a
-#endif
-
INCLUDES = \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
$(GNOME_CONDUIT_INCLUDEDIR) \
$(PISOCK_INCLUDEDIR) \
- $(ICAL_INCLUDEDIR) \
+ -I../libical/src/libical \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
GNOMECAL_CORBA_GENERATED = \
@@ -99,6 +94,8 @@ gnomecal_SOURCES = \
gnome-cal.c \
gnome-cal.h \
goto.c \
+ icalendar.c \
+ icalendar.h \
layout.c \
layout.h \
main.c \
@@ -118,8 +115,7 @@ gnomecal_SOURCES = \
view-utils.h \
view-utils.c \
year-view.c \
- year-view.h \
- $(ICAL_SOURCES)
+ year-view.h
calendar_pilot_sync_SOURCES = \
GnomeCal-common.c \
@@ -148,6 +144,8 @@ tlacuache_SOURCES = \
cal-util.h \
calobj.c \
calobj.h \
+ icalendar.c \
+ icalendar.h \
job.c \
job.h \
timeutil.c \
@@ -166,7 +164,8 @@ tlacuache_INCLUDES = \
tlacuache_LDADD = \
$(BONOBO_VFS_GNOME_LIBS) \
- ../libversit/libversit.la
+ ../libversit/libversit.la \
+ $(ICAL_LINK_FLAGS)
calendar_pilot_sync_LDADD = \
$(PISOCK_LIBDIR) $(PISOCK_LIBS) \