aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-01-25 11:17:54 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-01-25 11:17:54 +0800
commit32ce476a23e9f2757e9cc539532f38f4ab21837c (patch)
tree4a9aeebfe355427fe035d27441b02bbc7be0bc4d /calendar/Makefile.am
parent50e5c22f0f5c4083ceee623b5bc02a6a7fc4f18c (diff)
downloadgsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.gz
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.bz2
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.lz
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.xz
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.zst
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.zip
Added the gnome-pilot and capplet checks; they will likely be reworked for
2000-01-24 Federico Mena Quintero <federico@helixcode.com> * configure.in: Added the gnome-pilot and capplet checks; they will likely be reworked for the Evolution framework, but for now the calendar/ directory needs them. * configure.in: Added checks for gnome-vfs. 2000-01-24 Federico Mena Quintero <federico@helixcode.com> * tlacuache.c: New main module for the Tlacuache personal calendar server. * tlacuache.gnorba: New gnorba file for Tlacuache, the GNOME personal calendar server. * Makefile.am: Added the stuff necessary to build Tlacuache. * cal.c (Cal_get_uri): Convert the URI to a string before returning it. * cal-factory.c (CalFactory_create): Doh, this function is void. * job.c (job_add): Use g_idle_add(), not gtk_idle_add(). svn path=/trunk/; revision=1623
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am54
1 files changed, 47 insertions, 7 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 006102a2a7..135ffc4926 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -1,10 +1,14 @@
SUBDIRS = doc
idldir = $(datadir)/idl
-idl_DATA = GnomeCal.idl
+idl_DATA = \
+ GnomeCal.idl \
+ gnome-calendar.idl
gnorbadir = $(sysconfdir)/CORBA/servers
-gnorba_DATA = gnomecal.gnorba
+gnorba_DATA = \
+ gnomecal.gnorba \
+ tlacuache.gnorba
help_base = $(datadir)/gnome/help/cal
@@ -13,7 +17,8 @@ extra_pilot_bins = \
calendar-conduit-control-applet \
calendar-pilot-sync
endif
-bin_PROGRAMS = gnomecal $(extra_pilot_bins)
+
+bin_PROGRAMS = gnomecal tlacuache $(extra_pilot_bins)
INCLUDES = \
-I$(includedir) \
@@ -29,11 +34,8 @@ GNOMECAL_CORBA_GENERATED = \
GnomeCal-skels.c \
GnomeCal-stubs.c
-$(GNOMECAL_CORBA_GENERATED): my_gnomecal_idl
-
-my_gnomecal_idl: GnomeCal.idl
+$(GNOMECAL_CORBA_GENERATED): GnomeCal.idl
orbit-idl $(srcdir)/GnomeCal.idl
- touch my_gnomecal_idl
corba-cal.c \
corba-cal.h \
@@ -107,12 +109,46 @@ calendar_pilot_sync_SOURCES = \
timeutil.c \
timeutil.h
+GNOME_CALENDAR_CORBA_GENERATED = \
+ gnome-calendar.h \
+ gnome-calendar-common.c \
+ gnome-calendar-skels.c \
+ gnome-calendar-stubs.c
+
+$(GNOME_CALENDAR_CORBA_GENERATED): gnome-calendar.idl
+ orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl $(srcdir)/gnome-calendar.idl
+
+tlacuache_SOURCES = \
+ $(GNOME_CALENDAR_CORBA_GENERATED) \
+ cal.c \
+ cal.h \
+ cal-backend.c \
+ cal-backend.h \
+ cal-common.h \
+ cal-factory.c \
+ cal-factory.h \
+ calobj.c \
+ calobj.h \
+ job.c \
+ job.h \
+ timeutil.c \
+ timeutil.h \
+ tlacuache.c
+
LINK_FLAGS = \
$(GNOME_LIBDIR) \
$(GNOMEGNORBA_LIBS) \
$(INTLLIBS) \
../libversit/libversit.la
+tlacuache_INCLUDES = \
+ $(INCLUDES) \
+ -DG_LOG_DOMAIN=\"tlacuache\"
+
+tlacuache_LDADD = \
+ $(BONOBO_VFS_GNOME_LIBS) \
+ ../libversit/libversit.la
+
calendar_pilot_sync_LDADD = \
$(PISOCK_LIBDIR) $(PISOCK_LIBS) \
$(LINK_FLAGS)
@@ -185,6 +221,10 @@ calendar_conduit_control_applet_LDADD = \
# $(GNOME_PILOT_LIBS) \
# $(INTLLIBS)
+gnomecal_INCLUDES = \
+ $(INCLUDES) \
+ -DG_LOG_DOMAIN=\"gnomecal\"
+
gnomecal_LDADD = $(LINK_FLAGS)
if HAVE_GNOME_PILOT