aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
authorRussell Steinthal <rms39@columbia.edu>2000-02-16 22:27:38 +0800
committerSeth Alves <alves@src.gnome.org>2000-02-16 22:27:38 +0800
commit08f2b4e43ff25f5be620bfb3a3e3786b57849ad5 (patch)
treec0bf25e53209065c401325d27580982ac30c6e87 /calendar/Makefile.am
parentf926f10e86aee8df632613d9c5b5022e6b8597ca (diff)
downloadgsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.tar
gsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.tar.gz
gsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.tar.bz2
gsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.tar.lz
gsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.tar.xz
gsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.tar.zst
gsoc2013-evolution-08f2b4e43ff25f5be620bfb3a3e3786b57849ad5.zip
Change iCalObject.organizer from char* to iCalPerson*
2000-02-16 Russell Steinthal <rms39@columbia.edu> * calobj.[ch], eventedit.c, main.c: Change iCalObject.organizer from char* to iCalPerson* * calobj.[ch]: Change iCalObject.related from list of char* to list of iCalRelation*; assorted related fixes * icalendar.c: interface between libical and the gnomecal internal representation svn path=/trunk/; revision=1791
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 8fab42d57c..1762bc0bf7 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -20,11 +20,19 @@ endif
bin_PROGRAMS = gnomecal tlacuache $(extra_pilot_bins)
+#if HAVE_LIBICAL
+ICAL_INCLUDEDIR = -I../libical/src/libical
+ICAL_SOURCES = icalendar.c
+ICAL_LINK_FLAGS = ../libical/src/libical/libical.a
+#endif
+
+
INCLUDES = \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
$(GNOME_CONDUIT_INCLUDEDIR) \
$(PISOCK_INCLUDEDIR) \
+ $(ICAL_INCLUDEDIR) \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
GNOMECAL_CORBA_GENERATED = \
@@ -110,7 +118,8 @@ gnomecal_SOURCES = \
view-utils.h \
view-utils.c \
year-view.c \
- year-view.h
+ year-view.h \
+ $(ICAL_SOURCES)
calendar_pilot_sync_SOURCES = \
GnomeCal-common.c \
@@ -148,7 +157,8 @@ tlacuache_SOURCES = \
LINK_FLAGS = \
$(BONOBO_VFS_GNOME_LIBS) \
$(INTLLIBS) \
- ../libversit/libversit.la
+ ../libversit/libversit.la \
+ $(ICAL_LINK_FLAGS)
tlacuache_INCLUDES = \
$(INCLUDES) \