aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac106
1 files changed, 1 insertions, 105 deletions
diff --git a/configure.ac b/configure.ac
index d6e86d4565..44c9679e6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -487,111 +487,7 @@ else
fi
-AC_CHECK_FUNCS(mkstemp mkdtemp isblank)
-
-dnl **************************************************
-dnl ctime_r prototype
-dnl **************************************************
-
-AC_CACHE_CHECK([if ctime_r wants three arguments], [ac_cv_ctime_r_three_args],
-[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[ #include <time.h> ]],
- [[ char *buf;
- time_t date;
- ctime_r (&date, buf, 100); ]]
- )],[ac_cv_ctime_r_three_args=yes],[ac_cv_ctime_r_three_args=no])
-])
-
-if test x"$ac_cv_ctime_r_three_args" = xyes ; then
- AC_DEFINE(CTIME_R_THREE_ARGS, 1, [Solaris-style ctime_r])
-fi
-
-dnl **************************************************
-dnl gethostbyname_r prototype
-dnl **************************************************
-
-AC_CHECK_FUNCS(gethostbyname_r,[
-AC_CACHE_CHECK([if gethostbyname_r wants five arguments], [ac_cv_gethostbyname_r_five_args],
-[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[
- #include "confdefs.h"
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
-
- #define BUFSIZE (sizeof(struct hostent)+10)
- ]],
- [[
- struct hostent hent;
- char buffer[BUFSIZE];
- int bufsize=BUFSIZE;
- int h_errno;
- (void)gethostbyname_r ("www.ximian.com", &hent, buffer, bufsize, &h_errno);
- ]]
- )],[ac_cv_gethostbyname_r_five_args=yes],[ac_cv_gethostbyname_r_five_args=no])
-])])
-
-if test "x$ac_cv_gethostbyname_r_five_args" = "xyes" ; then
- AC_DEFINE(GETHOSTBYNAME_R_FIVE_ARGS, 1, [Solaris-style gethostbyname_r])
-fi
-
-dnl **************************************************
-dnl gethostbyaddr_r prototype
-dnl **************************************************
-
-AC_CHECK_FUNCS(gethostbyaddr_r,[
-AC_CACHE_CHECK([if gethostbyaddr_r wants seven arguments], [ac_cv_gethostbyaddr_r_seven_args],
-[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[
- #include "confdefs.h"
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
- #define BUFSIZE (sizeof(struct hostent)+10)
- ]],
- [[
- struct hostent hent;
- char buffer[BUFSIZE];
- int bufsize=BUFSIZE;
- int h_errno;
- (void)gethostbyaddr_r ("www.ximian.com", 14, AF_INET, &hent, buffer, bufsize, &h_errno); ]]
- )],[ac_cv_gethostbyaddr_r_seven_args=yes],[ac_cv_gethostbyaddr_r_seven_args=no])
-])])
-
-if test "x$ac_cv_gethostbyaddr_r_seven_args" = "xyes" ; then
- AC_DEFINE(GETHOSTBYADDR_R_SEVEN_ARGS, 1, [Solaris-style gethostbyaddr_r])
-fi
-
-dnl **************************************************
-dnl stat(v)fs location/type
-dnl **************************************************
-
-AC_CHECK_HEADER([sys/statvfs.h],
- [AC_DEFINE([HAVE_SYS_STATVFS_H], 1, [Have <sys/statvfs.h>])],,
- [[ #if HAVE_SYS_STATVFS_H
- #include <sys/statvfs.h>
- #endif
- ]])
-AC_CHECK_FUNCS(statvfs)
-
-AC_CHECK_HEADER([sys/param.h],
- [AC_DEFINE([HAVE_SYS_PARAM_H], 1, [Have <sys/param.h>])],,
- [[ #if HAVE_SYS_PARAM_H
- #include <sys/param.h>
- #endif
- ]])
-AC_CHECK_HEADER([sys/mount.h],
- [AC_DEFINE([HAVE_SYS_MOUNT_H], 1, [Have <sys/mount.h>])],,
- [[ #if HAVE_SYS_MOUNT_H
- #include <sys/mount.h>
- #endif
- ]])
-AC_CHECK_FUNCS(statfs)
+AC_CHECK_FUNCS(mkdtemp)
dnl **************************************************
dnl Gnome Icon Theme